Symptom
You may find that a batch of documents in an exceptions stage/task in ABBYY FlexiCapture.
If you try to close an exceptions task you will see this message:
The message above indicates that you must decide what action should happen next. For instance, send to Export to retry an export operation.
Cause
'Exceptions' is a catch-all state for documents in FlexiCapture. Documents will arrive in Exceptions for all sorts of reasons but commonly:
- A document arrived at the Export stage with rule errors (red flag) - "Cannot export a document with rule errors"
- An unknown document made it through to Exceptions and no action is defined for Unknown docs.
- An external resource was not available during export, e.g. API or database not available, a file may have been locked.
- There was a script error in a custom stage.
All documents in Exceptions must be specifically actioned. They may need to be deleted (be careful!) or sent to other stages.
Resolution
Select one or more documents, right-click, "Mark for sending to..." (or Ctrl+Shift+Q)
Then select the stage where the document(s) should be sent:
You will see that, when sending to a 'User stage', it's possible to add a Task comment for the benefit of the next person to see this task.
It's also possible to send different documents to different stages. Some might already be exported so these could be sent to Processed (the 'parking' stage which is at the end of the process), some could go to Verification for one user, others go to Exceptions (again) with a useful comment for IT support/administrator who may be expected to action them.
Was this article helpful?
That’s Great!
Thank you for your feedback
Sorry! We couldn't be helpful
Thank you for your feedback
Feedback sent
We appreciate your effort and will try to fix the article