Access to ABBYY FlexiCapture FlexiCapture12LocalProjects temp files is denied

Created by Jeremy Burgess, Modified on Thu, 5 Dec, 2024 at 11:48 AM by Jeremy Burgess

Symptoms

When using ABBYY FlexiCapture Standalone edition (or Project Setup Station) you see a message similar to:


ABBYY FlexiCapture 12 (Administrator Station)


⚠️ Access to C:\Users\****\OneDrive\Documents\FlexiCapture12LocalProjects\My Project - a98d02c7-1ea3-4e81-8948-39beca9ec45a\TestBatch\scan6gu7o.tmp was denied.


Cause

OneDrive is trying to sync the temporary files in ABBYY FlexiCapture's local temp folder. The files are created and deleted very quickly and the file sync can lock them, causing the issue.


This is also known to impact Google Drive and Dropbox file sync for the same reasons.


Resolution

Either:

  1. Stop the automatic cloud sync for the affected folder
    C:\Users\****\OneDrive\Documents\FlexiCapture12LocalProjects


  2. Move the folder to a different location which is not backed up. The folder path is defined in the registry location:
    Computer\HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\12.0\Shell\StartUp\PersonalPath

    Bear in mind that it is possible that more than one user is logged into the PC at the same time so it's sensible to use a different path per user, e.g.
    c:\ABBYYFlexicapture.temp\%username%\

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