Hot Folder Import Error: Access denied. Contact your Administrator

Created by Brett Cox, Modified on Tue, 11 Apr, 2023 at 9:48 AM by Brett Cox

Symptoms

When importing files from a hot folder the processing station will generate an error which can be seen in the task log on the processing server. The error is as per below:




Cause

During the upgrade from v12 r3 to v12 r4 record in the PrinciplePermission table are updated incorrectly. Prior to the upgrade there are records that have 'null' as the value in BatchTypeId field. After the upgrade these values are set to '0'



Resolution

Update the PrinciplePermission table and set the value of the BatchTypeId field to 'null' wherever a record contains a value if '0' in that field.

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