Symptoms
Mail Attachment Downloader [MAD] may not be able to communicate with the internet in order to validate the licence or to download emails from external servers.
Cause
There may be a complete block on internet activity for the host machine but, more than likely, MAD has been installed to a machine where one of the following is true.
- The mail server settings (host, port, TLS and protocol) are not correct
- The program cannot connect to the host, port possibly due to a firewall or some other block when connecting to that host/port
- Your internet connection may be down
Resolution
- First check the issue is not due to TLS 1.2 connectivity
- Check the MAD connection settings (server name, credentials) first.
- Check proxy settings
Proxy Settings
You may be behind a proxy preventing direct connection with gearmage.com on ports 80 and 443.
In the following TWO files in the Program Files Gearmage program / installation directory,
MailAttachmentDownloader.exe.config AND MailAttachmentDownloaderService.exe.config
You can try to change the proxy line here:
<defaultProxy/>
to
<defaultProxy enabled="true" useDefaultCredentials="true"> <proxy usesystemdefault="true" bypassonlocal="true"/> </defaultProxy>
or
<defaultProxy> <proxy proxyaddress="http://[proxy address]:[proxy port]" bypassonlocal="false"/> </defaultProxy>
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