Restarting Mail Attachment Downloader [MAD] Service

Created by Ethan Wyatt, Modified on Thu, 25 Nov, 2021 at 11:18 AM by Jeremy Burgess

Symptoms

The role of Mail Attachment Downloader [MAD] is to regularly monitor a number of mailboxes and use predefined rules to download, manpulate and process attachments.


Now and again the service can stop unexpectedly or may not be running completely.

Cause

Check the logs! Normally located at "C:\Windows\Temp\MailAttchmentDownloader\ServiceLog-Error.txt". Try to establish an underlying cause.


Examples of failures can include, for example, the o365 autodiscovery service failing, at times, to resolve the mailbox. It's also possoble that a single rogue item - an incorrectly structured email - can bung up the pipe causing each polling session to fail.


Generally the failures are not issues with MAD, per se, but MAD's failure is how you find out about the otherwise bad data.

Resolution

Use the MAD GUI to have a look at current status and/or the download history tab. When running the software as an administrator you should be able to see a live 'log' of the activity.


Check that the MailAttachmentDownloaderService is running. In Windows Services find the MailAttachmentDownloaderService.


If it indicates that the service is already running then you can Stop or Restart. Be patient because if a download operation is actively working the shutdown request can take some time. Start the service from service the manager.



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