Symptoms
Users receive the following error when trying to open a cabinet within File Director.
If you inspect the 'conversation' using Fiddler and find the the 'Error 500' response you may see the following in the XML data. Example Fiddler trace is attached to this solution.
<faultactor>Fields.GetWithPos</faultactor>
Cause
An index field had been created and then deleted at some point. This can leave 'orphan' data in the DocTypeFields table for that FileDirector cabinet database. An example query from that table is below. The combination of DocTypeID and FieldID is invalid - one or the other, or both do not exist.
In our example data, the highlighted row in red below was the cause. The FieldID 9605BFD6 no longer existed and caused the error 500 when the WinClient attempted to connect to this cabinet and create the document search/edit UI using the non-existent field.
Resolution
Remove the errant row(s). row marked in red.
Finally, restart IIS on the FIleDirector server using the command line iisreset command (run as administrator).
Was this article helpful?
That’s Great!
Thank you for your feedback
Sorry! We couldn't be helpful
Thank you for your feedback
Feedback sent
We appreciate your effort and will try to fix the article