FileDirector WinClient - unable to add/upload a new document

Created by Jeremy Burgess, Modified on Thu, 7 Nov, 2024 at 11:47 AM by Jeremy Burgess

Symptoms

When using the FileDirector WinClient you can add/upload a new document by either:

  1. Dragging the file onto the WinClient window
  2. In File Explorer you right-click, Send To..., FileDirector

The expected behaviour is that an indexing window will pop up allowing you to choose the document type and specify the indexing information.


In this case the indexing window does not appear; WinClient may become unresponsive.

Cause

When uploading a new document FileDirector uses the Component Services as well as the EDoc engine to manage content and file viewing / thumbnail / conversion operations. If one of these fails to operate then the file will not reach WinClient for indexing.

Resolution

1. Ensure that FileDirector Component Services is installed and running as a service


You can also use the powershell command:


PS C:\Users\Administrator> Get-WmiObject -Class Win32_Service | Where-Object { $_.Name -like "*FileDirector*" }

ExitCode  : 0
Name      : FileDirector Component Service
ProcessId : 7892
StartMode : Auto
State     : Running
Status    : OK


See also: Installing FileDirector Component Services


2. Ensure that the EDoc service is running, this should be visible in Windows task manager.


You can also use the powershell command:


PS C:\Users\Administrator> Get-Process | Where-Object { $_.ProcessName -like "*FileDirector*" }

 NPM(K)    PM(M)      WS(M)     CPU(s)      Id  SI ProcessName
 ------    -----      -----     ------      --  -- -----------
     26    17.99      17.52       0.81    7892   0 FileDirector Component Service
     34    19.96      18.33       0.66    8412   0 FileDirector EDoc Engine

3. Check that Microsoft Visual C++ Redistributable packages are properly installed

See: Install Microsoft Visual C++ Redistributable packages for FileDirector WinClient


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