OneDrive file sync causes issues with FileDirector WinClient

Created by Jeremy Burgess, Modified on Wed, 15 Jan at 10:40 AM by Jeremy Burgess

Symptoms

FileDIrector WinClient can experience issues with:

  • Uploading documents - although a document upload completes without error you subsequently find a zero page document in FileDirector.
  • Downloading a document - you may see an error message, or the application becomes unresponsive.
  • Editing/re-indexing a document - when making changes to a document and committing these [check-in] you may see errors or, when subsequently retrieving the document, the edit did not save successfully to the server.


You may also see messages, as below, indicating that "FileDirector Windows Client is downloading from [OneDrive]".

Screenshow showing a message "FileDirector Windows Client is downloading from [OneDrive]"

Cause

When uploading new/changed files and when viewing documents the FileDirector WinClient uses a LocalCachePath to store intermediate files used for indexing and document thumbnail/conversion. The normal path for these documents is %userprofile%\Documents\FileDirector (e.g. c:\users\myusername\documents\FileDirector)


When Microsoft OneDrive is installed it will, by default, replace the normal user document folder at %userprofile%\Documents\FileDirector with a cloud-synced folder at %userprofile%\Documents\OneDrive\FileDirector (or a similar %userprofile%\Documents\OneDrive - Your Company Ltd\FileDirector).


OneDrive is constantly monitoring this folder and will attempt cloud sync. At the same time FileDirector is using this folder to quickly create and destroy temporary files. When the two applications attempt to access, and potentially lock, the same file(s) this can cause unpredictable behaviour.


Additionally, the overall file path for most files in Windows (certainly with a Win32 application) should not exceed 255 characters; the use of a longer file path when OneDrive folder names are taken into account is more likely to create this situation.


The same results could occur with any other similar cloud-sync applications (e.g. Dropbox, Google Drive) where the user's 'My Documents' folder is remapped.

Resolution

The FileDirector LocalCachePath is intended for temporary files only. It need not, and should not, be in a location which contends with any other application and should be considerate to the maximum length for a filename with path.


The article "The specified path, file name, or both are too long" describes the method used to change the LocalCachePath for a user's PC.

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