No FileDirector Tab in MS Office (Component Services)

Created by Jeremy Burgess, Modified on Mon, 29 Jul at 12:46 PM by Jeremy Burgess

Symptoms

When installing File Director Component Services you should be seeing a File Director tab within Outlook, Excel and other Microsoft Office applications. However, you may not be seeing this.


Cause

DLL not registered or incorrect version of adxloader*.dll

The source of this problem could within the architecture version of adxloader installed, make sure tht the correct version is running in your environment:

  • Windows 32 or 64 bit with 32 bit MS Office - adxloader.dll needs to be installed
  • Windows 64 bit with 64 bit MS Office - adxloader64.dll needs to be installed


MS Office Plugin Behaviour

Another likely cause it that the plugin itself may be not be set to run at startup:


Resolution

We would recommend that you check you have installed the component services correctly by ticking the OfficeLink button in the installation for FileDirector Component Services. You might consider reinstalling Component Services completely.


Check MS Office for the FileDirector tab. Close MS Office and check that it's still there.


To install the correct version of adxloader*.dll

Before following the steps below, make sure that you understand how to use the correct version of regsvr32.


Note On a 64-bit version of Windows operating system, there are two versions of the Regsvr32.exe file:

  • The 32-bit version is %systemroot%\System32\regsvr32.exe
  • The 64-bit version is %systemroot%\SysWoW64\regsvr32.exe


To use regsvr32 make sure that you open a command line window as Administrator searching for 'cmd', right click and Run as Administrator.


The adxloader*.dll files are located at C:\Program Files (x86)\Spielberg Solutions GmbH\FileDirector Component Service\


To unregister a DLL use the command:

regsvr32 /i /u <filename>.dll


And to register, use:

regsvr32 /i <filename>.dll


For instance, if you run 64-bit MS Office you should unregister the 32-bit DLL then register the 64-bit version as follows:

regsvr32 /i /u adxloader.dll
regsvr32 /i adxloader64.dll


Check MS Office for the FileDirector tab. Close MS Office and check that it's still there.


MS Office Plugin Behaviour

In some cases, our Office add-ins may be disabled in Word, Excel, or Outlook. You can check this on the add-ins manager. Make sure you also check 'Slow and Disabled Add-ins' as well as Disabled Items.


Enabling Add-ins in MS Office

  1. Go to File > Options > Add-ins.
  2. Under Manage, select Disabled Add-ins.
  3. Highlight the add-in, then click Enable. If the add-in is not listed there, then just click close.
  4. Go back to the Add-ins menu. Again, under Manage, select COM Add-ins. Here you can activate the add-in by checking the box.
  5. Click OK.

Changing the Load Behavior

If you have enabling, as above, add-ins are still not loading when the application is opened, then it may be due to a registry setting. This registry setting determines how the add-in is loaded within MS Office applications.


Under Add-ins in Word (or Excel) you will see the current load behavior of the particular add-in. The load behavior of the add-in should be set to "Load at Startup." 


If the load behavior is "Unloaded" then follow these steps:

  1. Open your registry editor (open your Windows Start menu and type "regedit")
  2. Go to the add-in settings for your application (see list below)
    e.g. HKEY_CURRENT_USER > Software > Microsoft > Office > Word > Addins > OfficeLink
  3. Look for an entry called LoadBehavior with a type of REG_DWORD, it may not be there
  4. Note what the LoadBehavior is set to. It will be a number like 0 or 1 or 3.

If there is no LoadBehavior entry then you can create a REG_DWORD and give it the value 3.


Here are the full registry paths for each Office application:

  • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\Word\Addins\OfficeLink  
  • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\Excel\Addins\OfficeLink 
  • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\Outlook\Addins\OfficeLink 
  • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\PowerPoint\Addins\OfficeLink 


If the LoadBehavior is anything other than "3" then follow these steps:

  1. Close Word (or Excel or Outlook). Make sure the "winword.exe" (or relevant) process is not running in the Windows Task Manager. 
  2. Open the registry editor again. Double-click the registry key to edit it. If it does not exist then create a REG_DWORD key called LoadBehavior.
  3. Change the Load Behavior to "3." Close the registry editor.
  4. Re-open the registry editor to ensure "3" is still there.
  5. Open Word. The add-in should now load automatically at startup.  


See this MSDN article or more information about the LoadBehavior values: https://msdn.microsoft.com/en-us/library/bb386106.aspx#LoadBehavior 

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